re = /https?:[a-zA-Z0-9_.+-\/#~]+ /m
str = '眼影盤長這樣 http://i.imgur.com/uxvRo3h.jpg 說真的 很不好拍'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end