using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id=(.+)&";
string input = @"https://play.google.com/store/apps/details?id=com.alibaba.aliexpresshd&hl=en";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}