package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`id=(.+)&`)
var str = `https://play.google.com/store/apps/details?id=com.alibaba.aliexpresshd&hl=en`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}