$re = '/id=(.+)&/';
$str = 'https://play.google.com/store/apps/details?id=com.alibaba.aliexpresshd&hl=en';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);