package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:kilograms?|kilos?|kg)|(?:\d{0,4}(?:\.\d{1,6})))\s*((?:kilograms?|kilos?|kg)|(?:\d{0,4}(?:\.\d{1,6})))`)
var str = `This is some text 14.56 kg and some other text
This is some text kg 14.56 and some other text
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}