re = /((?:kilograms?|kilos?|kg)|(?:\d{0,4}(?:\.\d{1,6})))\s*((?:kilograms?|kilos?|kg)|(?:\d{0,4}(?:\.\d{1,6})))/m
str = 'This is some text 14.56 kg and some other text
This is some text kg 14.56 and some other text
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end