import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:kilograms?|kilos?|kg)|(?:\\d{0,4}(?:\\.\\d{1,6})))\\s*((?:kilograms?|kilos?|kg)|(?:\\d{0,4}(?:\\.\\d{1,6})))";
final String string = "This is some text 14.56 kg and some other text\n\n"
+ "This is some text kg 14.56 and some other text\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}