const regex = /((?:kilograms?|kilos?|kg)|(?:\d{0,4}(?:\.\d{1,6})))\s*((?:kilograms?|kilos?|kg)|(?:\d{0,4}(?:\.\d{1,6})))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:kilograms?|kilos?|kg)|(?:\\d{0,4}(?:\\.\\d{1,6})))\\s*((?:kilograms?|kilos?|kg)|(?:\\d{0,4}(?:\\.\\d{1,6})))', 'gm')
const str = `This is some text 14.56 kg and some other text
This is some text kg 14.56 and some other text
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}