import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"([^\"]+\\?(image([^&]*))[^\"])\"";
final String string = "<a class=\"MagicZoomPlus\" title=\"\" id=\"MagicZoomPlusImage4099\" href=\"http://www.shopdoscabelos.com.br/media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/k/i/kit-bomba-de-chocolate-forever-liss-1.jpg\"></a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}