$re = '/href="([^"]+\?(image([^&]*))[^"])"/m';
$str = '<a class="MagicZoomPlus" title="" id="MagicZoomPlusImage4099" href="http://www.shopdoscabelos.com.br/media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/k/i/kit-bomba-de-chocolate-forever-liss-1.jpg"></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);