const regex = /href="([^"]+\?(image([^&]*))[^"])"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="([^"]+\\?(image([^&]*))[^"])"', 'gm')
const str = `<a class="MagicZoomPlus" title="" id="MagicZoomPlusImage4099" href="http://www.shopdoscabelos.com.br/media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/k/i/kit-bomba-de-chocolate-forever-liss-1.jpg"></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}