// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href="([^"]+\?(image([^&]*))[^"])""#).unwrap();
let string = "<a class=\"MagicZoomPlus\" title=\"\" id=\"MagicZoomPlusImage4099\" href=\"http://www.shopdoscabelos.com.br/media/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/k/i/kit-bomba-de-chocolate-forever-liss-1.jpg\"></a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}