#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""title":\s*"([^"]+)""
Local $sString = "{" & @CRLF & _
" "kind": "books#volumes"," & @CRLF & _
" "totalItems": 1," & @CRLF & _
" "items": [" & @CRLF & _
" {" & @CRLF & _
" "kind": "books#volume"," & @CRLF & _
" "id": "HDvHjwEACAAJ"," & @CRLF & _
" "etag": "+2K7d2N2VNg"," & @CRLF & _
" "selfLink": "https://www.googleapis.com/books/v1/volumes/HDvHjwEACAAJ"," & @CRLF & _
" "volumeInfo": {" & @CRLF & _
" "title": "Fahrenheit 451"," & @CRLF & _
" "authors": [" & @CRLF & _
" "Ray Bradbury"" & @CRLF & _
" ]," & @CRLF & _
" "publisher": "Voyager"," & @CRLF & _
" "publishedDate": "2013"," & @CRLF & _
" "description": "The terrifyingly prophetic novel of a post-literate future Guy Montag is a fireman. His job is to destroy the most illegal of commodities, the source of all discord and unhappiness, the printed book."," & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div style="padding-left:2em;">" & @CRLF & _
" • Location: " & @CRLF & _
"" & @CRLF & _
" Northern Virginia, ☎ 202-210-5936" & @CRLF & _
"" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div style="padding-left:2em;"><br />• Post ID: 1234567 washingtondc</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div id="OtherAdsByThisUser" data-oid="7654321">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")