const regex = /"title":\s*"([^"]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"title":\\s*"([^"]+)"', 'g')
const str = `{
"kind": "books#volumes",
"totalItems": 1,
"items": [
{
"kind": "books#volume",
"id": "HDvHjwEACAAJ",
"etag": "+2K7d2N2VNg",
"selfLink": "https://www.googleapis.com/books/v1/volumes/HDvHjwEACAAJ",
"volumeInfo": {
"title": "Fahrenheit 451",
"authors": [
"Ray Bradbury"
],
"publisher": "Voyager",
"publishedDate": "2013",
"description": "The terrifyingly prophetic novel of a post-literate future Guy Montag is a fireman. His job is to destroy the most illegal of commodities, the source of all discord and unhappiness, the printed book.",
<div style="padding-left:2em;">
• Location:
Northern Virginia, ☎ 202-210-5936
</div>
<div style="padding-left:2em;"><br />• Post ID: 1234567 washingtondc</div>
<div id="OtherAdsByThisUser" data-oid="7654321">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}