import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"title\":\\s*\"([^\"]+)\"";
final String string = "{\n"
+ " \"kind\": \"books#volumes\",\n"
+ " \"totalItems\": 1,\n"
+ " \"items\": [\n"
+ " {\n"
+ " \"kind\": \"books#volume\",\n"
+ " \"id\": \"HDvHjwEACAAJ\",\n"
+ " \"etag\": \"+2K7d2N2VNg\",\n"
+ " \"selfLink\": \"https://www.googleapis.com/books/v1/volumes/HDvHjwEACAAJ\",\n"
+ " \"volumeInfo\": {\n"
+ " \"title\": \"Fahrenheit 451\",\n"
+ " \"authors\": [\n"
+ " \"Ray Bradbury\"\n"
+ " ],\n"
+ " \"publisher\": \"Voyager\",\n"
+ " \"publishedDate\": \"2013\",\n"
+ " \"description\": \"The terrifyingly prophetic novel of a post-literate future Guy Montag is a fireman. His job is to destroy the most illegal of commodities, the source of all discord and unhappiness, the printed book.\",\n\n\n\n\n\n"
+ " <div style=\"padding-left:2em;\">\n"
+ " • Location: \n\n"
+ " Northern Virginia, ☎ 202-210-5936\n\n"
+ " </div>\n\n\n\n\n"
+ " <div style=\"padding-left:2em;\"><br />• Post ID: 1234567 washingtondc</div>\n\n\n"
+ " <div id=\"OtherAdsByThisUser\" data-oid=\"7654321\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}