package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{12})([A-HK-MRT-Y]{1})$`)
var str = `123123123123H
456456456778L
123123123123H`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}