$re = '/^(\d{12})([A-HK-MRT-Y]{1})$/m';
$str = '123123123123H
456456456778L
123123123123H';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);