const regex = /^(\d{12})([A-HK-MRT-Y]{1})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{12})([A-HK-MRT-Y]{1})$', 'gm')
const str = `123123123123H
456456456778L
123123123123H`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}