#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "e(?=\s|$|[\.!'"\-:;\?\(\)])"
Local $sString = "Some text to show this is matching words ending with "e". Bee-Bee: Bee! Bee? Bee; Bee" & @CRLF & _
"Bee\Bee/Bee and (Bee) but bee@bee.bee"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")