re = /e(?=\s|$|[\.!'"\-:;\?\(\)])/
str = 'Some text to show this is matching words ending with "e". Bee-Bee: Bee! Bee? Bee; Bee
Bee\\Bee/Bee and (Bee) but bee@bee.bee'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end