const regex = /e(?=\s|$|[\.!'"\-:;\?\(\)])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('e(?=\\s|$|[\\.!\'"\\-:;\\?\\(\\)])', 'g')
const str = `Some text to show this is matching words ending with "e". Bee-Bee: Bee! Bee? Bee; Bee
Bee\\Bee/Bee and (Bee) but bee@bee.bee`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}