import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "m[aeiouy]+w?";
final String string = "Meow\n"
+ "Mew\n"
+ "Catalan: Meu\n"
+ "Chinese: Mao\n"
+ "Danish: Miaav\n"
+ "Dutch: Miauw\n"
+ "Finnish: Miau or Kurnau\n"
+ "French: Miaou\n"
+ "Greek: Naiou\n"
+ "Hebrew: Miau or Miya\n"
+ "Hungarian: Miaaau\n"
+ "Japanese: Nyan\n"
+ "Korean: Yaong or Nyaong\n"
+ "Norwegian: Mjau\n"
+ "Portuguese: Miau\n"
+ "Spanish: Miau\n\n"
+ "meyw\n"
+ "myyyyyyyyyyyyyy\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}