const regex = /m[aeiouy]+w?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('m[aeiouy]+w?', 'gmi')
const str = `Meow
Mew
Catalan: Meu
Chinese: Mao
Danish: Miaav
Dutch: Miauw
Finnish: Miau or Kurnau
French: Miaou
Greek: Naiou
Hebrew: Miau or Miya
Hungarian: Miaaau
Japanese: Nyan
Korean: Yaong or Nyaong
Norwegian: Mjau
Portuguese: Miau
Spanish: Miau
meyw
myyyyyyyyyyyyyy
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}