$re = '/m[aeiouy]+w?/mi';
$str = 'Meow
Mew
Catalan: Meu
Chinese: Mao
Danish: Miaav
Dutch: Miauw
Finnish: Miau or Kurnau
French: Miaou
Greek: Naiou
Hebrew: Miau or Miya
Hungarian: Miaaau
Japanese: Nyan
Korean: Yaong or Nyaong
Norwegian: Mjau
Portuguese: Miau
Spanish: Miau
meyw
myyyyyyyyyyyyyy
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);