// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)m[aeiouy]+w?").unwrap();
let string = "Meow
Mew
Catalan: Meu
Chinese: Mao
Danish: Miaav
Dutch: Miauw
Finnish: Miau or Kurnau
French: Miaou
Greek: Naiou
Hebrew: Miau or Miya
Hungarian: Miaaau
Japanese: Nyan
Korean: Yaong or Nyaong
Norwegian: Mjau
Portuguese: Miau
Spanish: Miau
meyw
myyyyyyyyyyyyyy
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}