using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^hiv[\W_]\d{1,2}$";
string input = @"probe
hiv-1
dna
amp
probe
hiv-1
dna
quant
hiv-2
dna
dir
probe
hiv-2
dna";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}