const regex = new RegExp('^hiv[\\W_]\\d{1,2}$', 'mgi')
const str = `probe
hiv-1
dna
amp
probe
hiv-1
dna
quant
hiv-2
dna
dir
probe
hiv-2
dna`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}