// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^hiv[\W_]\d{1,2}$").unwrap();
let string = "probe
hiv-1
dna
amp
probe
hiv-1
dna
quant
hiv-2
dna
dir
probe
hiv-2
dna";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}