re = /^hiv[\W_]\d{1,2}$/mi
str = 'probe
hiv-1
dna
amp
probe
hiv-1
dna
quant
hiv-2
dna
dir
probe
hiv-2
dna'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end