import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bERROR:\\h.*|\\bOK:\\hALL\\hOK(?=\\h+\\([^()]*\\))";
final String string = "OK: ALL OK (8536972.66889)\n"
+ "ERROR: ioerror/8536615.22927\n"
+ "OK: ALL OK (8546369.92291)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}