import re
regex = re.compile(r"\bERROR:\h.*|\bOK:\hALL\hOK(?=\h+\([^()]*\))", flags=re.MULTILINE)
test_str = ("OK: ALL OK (8536972.66889)\n"
"ERROR: ioerror/8536615.22927\n"
"OK: ALL OK (8546369.92291)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")