# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=(?:.{5})+$)/:/gm;t' <<< "My Very Enthusiastic Mother Just Served Us Noodles!"