$re = '/(?=(?:.{5})+$)/m';
$str = 'My Very Enthusiastic Mother Just Served Us Noodles!';
$subst = ":";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;