import re
regex = re.compile(r"(?=(?:.{5})+$)", flags=re.MULTILINE)
test_str = "My Very Enthusiastic Mother Just Served Us Noodles!"
subst = ":"
result = regex.sub(subst, test_str)
if result:
print(result)