import Foundation
let pattern = #"(?=(?:.{5})+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"My Very Enthusiastic Mother Just Served Us Noodles!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)