import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?:\\G(?!^)\\s?,\\s?|#images\\s?=\\s?)(\\w+(?:-\\w+)*)";
final String string = "#build #images = image-a, image-b,image_c, imaged , image-e #setup=my-setup fixing issue with px";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}