re = /(?i)(?:\G(?!^)\s?,\s?|#images\s?=\s?)(\w+(?:-\w+)*)/m
str = '#build #images = image-a, image-b,image_c, imaged , image-e #setup=my-setup fixing issue with px'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end