const regex = new RegExp('(?i)(?:\\G(?!^)\\s?,\\s?|#images\\s?=\\s?)(\\w+(?:-\\w+)*)', 'gm')
const str = `#build #images = image-a, image-b,image_c, imaged , image-e #setup=my-setup fixing issue with px`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}