$re = '/(?i)(?:\G(?!^)\s?,\s?|#images\s?=\s?)(\w+(?:-\w+)*)/m';
$str = '#build #images = image-a, image-b,image_c, imaged , image-e #setup=my-setup fixing issue with px';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);