#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a[^>]*?href=\"([^>]*?)\"[^>]*?>(<img.*?src=\"(.*?)\".*?>)<\/a>"
Local $sString = "<a title="<abc>" " & @CRLF & _
" href = "enlace" " & @CRLF & _
" value="<def>"" & @CRLF & _
">" & @CRLF & _
"" & @CRLF & _
"<img title="<abc>" " & @CRLF & _
" href = "enlace" " & @CRLF & _
" value="<def>"" & @CRLF & _
">" & @CRLF & _
"" & @CRLF & _
"</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")