$re = '/<a[^>]*?href=\"([^>]*?)\"[^>]*?>(<img.*?src=\"(.*?)\".*?>)<\/a>/';
$str = '<a title="<abc>"
href = "enlace"
value="<def>"
>
<img title="<abc>"
href = "enlace"
value="<def>"
>
</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);