using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*?href=\""([^>]*?)\""[^>]*?>(<img.*?src=\""(.*?)\"".*?>)<\/a>";
string input = @"<a title=""<abc>""
href = ""enlace""
value=""<def>""
>
<img title=""<abc>""
href = ""enlace""
value=""<def>""
>
</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}