re = /<a[^>]*?href=\"([^>]*?)\"[^>]*?>(<img.*?src=\"(.*?)\".*?>)<\/a>/
str = '<a title="<abc>"
href = "enlace"
value="<def>"
>
<img title="<abc>"
href = "enlace"
value="<def>"
>
</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end