#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^#\w+$"
Local $sString = "valid inputs:" & @CRLF & _
"#hashtag_abc" & @CRLF & _
"#simpleHashtag" & @CRLF & _
"" & @CRLF & _
"Invalid inputs:" & @CRLF & _
"#hashtag#" & @CRLF & _
"#hashtag@hashtag"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")