re = /^#\w+$/m
str = 'valid inputs:
#hashtag_abc
#simpleHashtag
Invalid inputs:
#hashtag#
#hashtag@hashtag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end