$re = '/^#\w+$/m';
$str = 'valid inputs:
#hashtag_abc
#simpleHashtag
Invalid inputs:
#hashtag#
#hashtag@hashtag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);