using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https://docs.google.com/spreadsheets/d/(?<sheet_id>[a-zA-Z0-9\-_]+?)/\w*(\#gid=(?<gid>[0-9]+))?$";
string input = @"https://docs.google.com/spreadsheets/d/1qpnrhNW04i5bazsDMTxC_jjKX1txaNJuCPS1Ml8Q-is/edit#gid=2060287723";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}