import Foundation
let pattern = ##"^https://docs.google.com/spreadsheets/d/(?<sheet_id>[a-zA-Z0-9\-_]+?)/\w*(\#gid=(?<gid>[0-9]+))?$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"https://docs.google.com/spreadsheets/d/1qpnrhNW04i5bazsDMTxC_jjKX1txaNJuCPS1Ml8Q-is/edit#gid=2060287723"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)