package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https://docs.google.com/spreadsheets/d/(?<sheet_id>[a-zA-Z0-9\-_]+?)/\w*(\#gid=(?<gid>[0-9]+))?$`)
var str = `https://docs.google.com/spreadsheets/d/1qpnrhNW04i5bazsDMTxC_jjKX1txaNJuCPS1Ml8Q-is/edit#gid=2060287723`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}