use strict;
my $str = 'https://docs.google.com/spreadsheets/d/1qpnrhNW04i5bazsDMTxC_jjKX1txaNJuCPS1Ml8Q-is/edit#gid=2060287723';
my $regex = qr#^https://docs.google.com/spreadsheets/d/(?<sheet_id>[a-zA-Z0-9\-_]+?)/\w*(\#gid=(?<gid>[0-9]+))?$#mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}